Common Tasks
Note
This is a DRAFT document which may contain errors!
Help us improve and expand this site.
Please see the Contrib section for more details about joining the OpenIndiana Documentation Team.
< place holder for introduction content >
Basic UNIX commands
In addition to native command line system administration tools, OpenIndiana also includes the GNU core utilities suite. When working with basic UNIX commands, most likely you will be using the GNU core utilities. For learning to navigate the OpenIndiana command line environment, Linux command line books are very helpful.
One of the best books currently available is The Linux Command Line by William Shotts. If you want to quickly become a command line guru, this is the book to read. Best of all, it was released under a Creative Commons license and can be downloaded for free. Print versions are also available.
Basic system administration
Commands to be able to use administration commands
Command | Further details | Brief summary |
---|---|---|
su |
su(1M) | Switch user. Without any parameters, root implied |
sudo |
sudo(1M) | Perform the command following with root privilages |
pfexec |
pfexec(1) | Similar to sudo but not prompted for a password and limited privilages |
Examples:
Basic system information
Command | Further details | Brief summary |
---|---|---|
prstat |
prstat(1M) | Statistics on system processes |
df |
df(1M) | Disk usage by partition |
du |
du(1) | Disk usage by file |
pkg list |
pkg(1) | List software packages installed on the system |
Examples:
System shutdown, reboot…
Command | Further details | Brief summary |
---|---|---|
shutdown |
shutdown(1M) | Shutdown the system |
Examples:
shutdown -i5 -g0 -y # Turn off the machine immediately
shutdown -i6 -g0 -y # Reboot the machine immediately
shutdown -i6 -g120 -y # Reboot the machine in 2 minutes (120 seconds)
User management
Command | Further details | Brief summary |
---|---|---|
listusers |
listusers(1) | List users accounts |
who |
who(1) | List users logged onto the system |
useradd |
useradd(1M) | Create a new user |
usermod |
usermod(1M) | Modify a user (group memberships, roles, login shell…) |
Desktop applications
< place holder >
How can the desktop be modified?
Documentation Team
ITEMS TO WRITE ABOUT:
- Gnome or (MATE) walkthrough
- Appearance applet
- Enabling Compiz
- Configuring font anti-aliasing
- Desktop backgrounds
In regards to the default terminal emulator, see: https://www.illumos.org/issues/7525
- we introduce mediator x-terminal-emulator for link /usr/bin/x-terminal-emulator with possible implementations gnome-terminal, mate-terminal and xterm;
- mate-terminal implementation has the highest priority (if it is installed, by default it wins);
- glib is modified to use link /usr/bin/x-terminal-emulator if it's found for running applications with Terminal=true.
Multimedia - Audio
< Place Holder for future content >
Multimedia - Video
Documentation Team
ITEMS TO WRITE ABOUT:
- How to get OI to play a DVD
- How to get flash player installed and working.
- How to get VLC installed and working.
- Totem (video player)
Using OpenIndiana as a media server, HTPC, etc.
Documentation Team
ITEMS TO WRITE ABOUT:
Printing
Documentation Team
ITEMS TO WRITE ABOUT:
- OI uses CUPS as the primary print system.
- GNOME print manager (
system-config-printer
)
See the additional information about printing in contrib/topics.md Also see the deprecation comments in the OSOL printing guide.
Graphics workstation
Documentation Team
ITEMS TO WRITE ABOUT:
- GIMP
Desktop Publishing system, Etc.
< Place holder for content >
Boot loader settings
OpenIndiana Hipster uses the 'BootForth' boot loader (GRUB is not used any more, disregard older manusls/wiki pages that mention grub).
Boot configuration items should be stored in /boot/conf.d
.
-
To change the console from the standard monitor to serial console (e.g.
COM1
/ttyS0
on other OSes), use the following command:# echo console=ttya > /boot/conf.d/console
(Alternatively, use
eeprom console=ttya
). -
To change the boot-loader's default timeout, run:
# echo autoboot_delay=2 > /boot/conf.d/autoboot
NOTE:
Any filename can be used under /boot/conf.d/
- the filename does not
matter (only its content matters).
See loader(5) for more technical details (and other boot options).
Created: 2016-06-13 01:47:32